Создаём массив из 11 элементов, который называем Dat:
целтаб Dat[1:11]Объявляем переменные к и ш, являющимися целыми числами:
цел к, шЗаполняем массив Dat:
Dat[1]:=21 Dat[4]:=19 Dat[7]:=23 Dat[10]:=29 Dat[2]:=23 Dat[5]:=25 Dat[8]:=21 Dat[11]:=19 Dat[3]:=20 Dat[6]:=22 Dat[9]:=22Присваиваем переменной ш значение 0.
ш:=0Объявляем цикл от 1 до 11, то бишь пробегаемся по массиву Dat и смотрим, если значение элемента больше 22, то прибавляем к переменной ш 1:
нц для к от 1 до 11 если Dat[к]>22 то ш:=ш+1 Все кцВыводим на экран значение переменной ш:
вывод шТаким образом мы видим, что программа подсчитывает количество классов в которых больше 22 учеников. Таких классов будет 4: 2(23), 5(25), 7(23) и 10(29).
язык с++
Объяснение:
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "ru");
int number[15] = {4,6,8,10,12,14,16,18,20,22,24,26,28,30,32 };
cin >> number[0];
printf("%d\n", number[0]);
printf("%d\n", number[1]);
printf("%d\n", number[2]);
printf("%d\n", number[3]);
printf("%d\n", number[4]);
printf("%d\n", number[5]);
printf("%d\n", number[6]);
printf("%d\n", number[7]);
printf("%d\n", number[8]);
printf("%d\n", number[9]);
printf("%d\n", number[10]);
printf("%d\n", number[11]);
printf("%d\n", number[12]);
printf("%d\n", number[13]);
printf("%d\n", number[14]);
system("pause");
}
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу вычисления стоимости покупки, состоящей из нескольких книг. стоимость книги и количество вводится пользователем во время работы программы. если стоимость покупки составляет больше 500 рублей, то покупателю предоставляется скидка 5%.
Если нужно не на Python'е, напишите.