shuramuji
?>

Как в c++ написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. я пишу, вроде всё правильно делаю, но программа выдает: "hello, 0", чтобы я не вводила. #include ; using namespace std; int main() { int name; cout < < "what is your name? "; cin > > name; cout < < "hello, " < < name< < endl; return 0; }

Информатика

Ответы

Карен
По порядку:
1) Ты забыл подключить библиотеку <iostream> (надо было наприсать
#include <iostream>)
2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C++ - это string (Для ее использования необходимо ее подключить - #include <string>)

Итого
#include <iostream>
#include <string>

using namespace std;

int main() {
string name;
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name<< endl;
return 0;
}
axo-geo
Достаточно массива char str[10] и не нужно ничего лишнего подключать, прежде чем переходить к <string> из С++, стоить ознакомится со Си строками, тк <string> это только удобная обертка
arturo95

//PascalABC.NET версия 3.2, сборка 1389

//Если программа не запускается, то обновите версию

uses System.Linq;

begin

   writeln('III');

   var a := ReadArrInteger('Документы', ReadInteger('n=')).ToList;

   writeln;

   

   while a.Any() do

   begin

       write(a[0], ' ');

       a.RemoveAt(0);

       if not a.Any then break;

       

       write(a.Last, ' ');

       a.RemoveAt(a.Count - 1);

       if not a.Any then break;

       

       var n := 0;

       if a.Count > 1 then n := a.Count div 2 - 1;

       write(a[n], ' ');

       a.RemoveAt(n);

   end;

end.

Объяснение:

minasov19

//PascalABC.NET версия 3.2, сборка 1389

//Если программа не запускается, то обновите версию

uses System.Linq;

begin

   writeln('III');

   var a := ReadArrInteger('Документы', ReadInteger('n=')).ToList;

   writeln;

   

   while a.Any() do

   begin

       write(a[0], ' ');

       a.RemoveAt(0);

       if not a.Any then break;

       

       write(a.Last, ' ');

       a.RemoveAt(a.Count - 1);

       if not a.Any then break;

       

       var n := 0;

       if a.Count > 1 then n := a.Count div 2 - 1;

       write(a[n], ' ');

       a.RemoveAt(n);

   end;

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Как в c++ написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. я пишу, вроде всё правильно делаю, но программа выдает: "hello, 0", чтобы я не вводила. #include ; using namespace std; int main() { int name; cout < < "what is your name? "; cin > > name; cout < < "hello, " < < name< < endl; return 0; }
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Neveselova
Semenova1719
cafemgimo
Yekaterina358
Попов1946
nusupova
volna22051964
ocik1632933
egoryuzbashev
Рожнов
olimov9
JisesLove19955
bsi771184
daskal83
Sergei Vitalevna