gilmore886173
?>

С++ напишите программу, которая считывает целое число и выводит текст, аналогичный в примере. пробелы, знаки препинания, заглавные и строчные буквы важны! входные данные вводится целое число. выходные данные выведите ответ на . примеры входные данные 179 выходные данные the next number for the number 179 is 180. the previous number for the number 179 is 178.

Информатика

Ответы

avolodyaev

int main() {

int a;

cin >> a >> endl;

cout <<"The next number for the number " << a + 1 << endl << "The previous number for the number " <<  a - 1 << endl;

return 0;

}

Urmanov19903131
Диспетчер принимает заказ на такси. 
Принимает звуковую информацию, содержащую адрес подачи такси
Время 
и Адрес назначения.
Правило:
В соответствии с полученной информацией производит поиск по базе свободных таксистов и производит расчет стоимость по заданной формуле. 
Затем передает адреса и время таксисту а стоимость и номер машины клиенту.

Бабушка просит внучку включить на телевизоре какую-нибудь передачу про здоровье.

Получена звуковая информация, содержащая сообщение с задачей - переключать каналы, пока не встретится передача, соответствующая критерию - передача про здоровье.

Правило: 
переключать каналы, пока не встретится передача, соответствующая критерию - передача про здоровье.
Gennadevna_Baidalina131
Const
  Blanks = [' '];

function PosBlank(s: string; pn, pk: integer): integer;
{
  Ищет в строке s в позициях от pn до pk пробельный символ.
  Возвращает его позицию в строке или ноль, если таковой символ не найден.
  Использует подмножество пробельных символов Blanks, что позволяет определять
  произвольный набор пробельных символов (например, табуляцию и т.д.)
}
var
  p: integer;
  flag: boolean;

begin
  p := pn;
  flag := true;
  while flag and (p <= pk) do
  begin
    if s[p] in Blanks then flag := false
    else p := p + 1
  end;
  if p > pk then PosBlank := 0
  else PosBlank := p
end;

function PosNonBlank(s: string; pn, pk: integer): integer;
{
  Ищет в строке s в позициях от pn до pk непробельный символ.
  Возвращает его позицию в строке или ноль, если таковой символ не найден.
  Использует подмножество пробельных символов Blanks, что позволяет определять
  произвольный набор пробельных символов (например, табуляцию и т.д.)
}
var
  p: integer;
  flag: boolean;

begin
  p := pn;
  flag:=true;
  while flag and (p <= pk) do
  begin
    if s[p] in Blanks then p := p + 1
    else flag := false
  end;
  if p > pk then PosNonBlank := 0
  else PosNonBlank := p
end;

var
  s: string;
  i, l, k: integer;

begin
  Write('Введите строку: ');
  Readln(s);
  l := Length(s);
  k := 0;
  i := PosNonBlank(s, 1, l);
  while (i>0) and (i <= l) do
  begin
    k := k + 1;
    i := PosBlank(s, i + 1, l);
    if i = 0 then i := l + 1
    else i := PosNonBlank(s, i + 1, l)
  end;
  Writeln('Количество слов в строке равно ', k)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++ напишите программу, которая считывает целое число и выводит текст, аналогичный в примере. пробелы, знаки препинания, заглавные и строчные буквы важны! входные данные вводится целое число. выходные данные выведите ответ на . примеры входные данные 179 выходные данные the next number for the number 179 is 180. the previous number for the number 179 is 178.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lighturist
evada2
olkay
funny-furiya
misie1974
kav511
pizzaverona
kirik197308
Maksimova1320
klykovav672
lele4kass
Babushkina27
Vyacheslavovich-Gubanov
market-line5260
Александрович_Викторовна