Информатика 9 класс (напишите целиком ) написать программу: заполнить массив из 20 элементов случайными числами на интервале [-20, 25]. найти произведение элементов с четными номерами.
Var i,s: integer; a:array[1..20] of integer; begin s:=1; randomize; for i := 1 to 20 do a[i] := random(45)-20; for i:=1 to 20 do begin i:=i+1; s:=s*i; end; write(s); end.
проверяй в компиляторе, где-то накосячил
krtatiana69
20.05.2023
Const n1 = 20; m1 = 20;
var a: array[1..n1, 1..m1] of integer; b: array[1..m1] of integer; i, j, m, n: integer;
begin Write('Введите через пробел число строк и столбцов массива: '); Readln(n, m); Randomize; Writeln('Исходный массив'); for i := 1 to n do begin for j := 1 to m do begin a[i, j] := Random(101) - 50; Write(a[i, j]:4) end; Writeln end; Writeln('Сформированный массив'); for j := 1 to m do begin i := 1; while (i <= n) and (a[i, j] >= 0) do i := i + 1; if i <= n then b[j] := a[i, j] else b[j] := -99; Write(b[j]:4) end; Writeln end.
Программу надо сформатировать и тогда её структура будет видна лучше. А чтобы понять, как идет выполнение, в нужных точках ставим промежуточную выдачу - это называется "трассировкой".
var s, k: integer; label met; begin s:=-12; k:=90; Writeln('s=',s,', k=',k); s:=s+10; Writeln('s=',s); met: Writeln('Метка met:'); k:=k+10; Write('k=',k); if k<200 then s:=50 else s:=s+k; Writeln(', s=',s); if k<200 then goto met; Writeln('Результат: s=',s) end.
Информатика 9 класс (напишите целиком ) написать программу: заполнить массив из 20 элементов случайными числами на интервале [-20, 25]. найти произведение элементов с четными номерами.
begin
s:=1;
randomize;
for i := 1 to 20 do
a[i] := random(45)-20;
for i:=1 to 20 do
begin
i:=i+1;
s:=s*i;
end;
write(s);
end.
проверяй в компиляторе, где-то накосячил