rigina82
?>

Составьте программу как формирует маств с 9 случайных целых чисел что належыть промежутке [-3; 5 и выводит эти лица в столбик быстрее

Информатика

Ответы

fox-cab3444

import random

m=[]

for a in range(9):

   m.append(random.randint(-3,5))

for a in range(len(m)):

   print(m[a])


ответ на Python

sdy19576216
Первая программа:

Var
   N,A:integer;
   S:real;
Begin
S:=0;
Write('N = ');ReadLn(N);
For N:= 1 to N do
    Begin
    Read(A);
    if (A mod 5 = 0)and(A mod 10 < 0) then S:=S+A;
    End;
WriteLn('S = ',S);
End.

Пример работы программы:

N = 5
-5
10
15
-25
17
S = -30

Вторая программа:

Var
   A,N,k:integer;
Begin
k:=0;
Write('N = ');ReadLn(N);
For N:= 1 to N do
    Begin
    Read(A);
    A:=Abs(A);
    if (A mod 3 = 0)and((A mod 10 = 6)or(A mod 10 = 9)) then k:=k+1
    End;
WriteLn('k = ',k);
End.

Пример работы программы:

N = 3
756
12
39
k = 2
Yurevich1243
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу как формирует маств с 9 случайных целых чисел что належыть промежутке [-3; 5 и выводит эти лица в столбик быстрее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Boykoyelena
olartamonov6
st-op767840
DmitrievnaVera
snopok66
AndreevManaeva
natanikulina1735
katarinacorvus825
msangelika1010
maestro6838
madjk
Исаченко Тераски1181
I.B.Petrishchev
sleek73
О. Карпов1691