Казалось бы легкие задачи, а не получается...
Заранее огромное Вычислить среднее арифметическое тангенсов трех вещественных чисел.
Входные данные:
Во входном потоке в первой строке задано три вещественных числа. Значения чисел по модулю не превышают 1 000 000 000.
Выходные данные:В выходной поток вывести одно вещественное число с точностью пять знаков после запятой.
0
Лучшие ответы (1)
Сообщение: #3619519
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.10.2012, 19:48
ответы с готовыми решениями:
Вычислить среднее арифметическое тангенсов трех вещественных чисел
Вычислить среднее арифметическое тангенсов трех вещественных чисел. Входные данные: Во входном...
Найти среднее арифметическое трех вещественных чисел, заданных с клавиатуры
найти среднее арифметическое трех вещественных чисел, заданных с клавиатуры
Вычислить среднее арифметическое двух заданных вещественных чисел
Вычислить среднее арифметическое двух заданных вещественных чисел. Входные данные: Во входном...
Вывести массив из 50 вещественных чисел от 20 до 40, вычислить среднее арифметическое , посчитать количество элементов.
Добрый день.Задали задание, в паскале я только начинающий. Ничего не могу понять, как и что...
2
CodeR
Фрилансер
3402 / 2799 / 3000
Регистрация: 08.02.2012
Сообщений: 7,606
Записей в блоге: 1
28.10.2012, 08:55 2
Лучший ответ Сообщение было отмечено Cкорпион как решение
Решение
PascalВыделить код
1
2
y:=sin(a)/cos(a)+sin(b)/cos(b)+sin(c)/cos(c);
writeln(y/3:0:5);
так как в Паскале Abc нет стандартной функции tg поэтому выражаем через sin and cos
1
Cкорпион
1 / 1 / 5
Регистрация: 27.10.2012
Сообщений: 46
28.10.2012, 08:58 [ТС] 3
Цитата Сообщение от Artem7 Посмотреть сообщение
PascalВыделить код
1
2
y:=sin(a)/cos(a)+sin(b)/cos(b)+sin(c)/cos(c);
writeln(y/3:0:5);
так как в Паскале Abc нет стандартной функции tg поэтому выражаем через Думаю, если с тангенсами (как и с синусами и косинусами в паскале) разобраться, то ничего трудного в них не будет.
0
28.10.2012, 08:58
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.10.2012, 08:58
Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.
Определить среднее арифметическое вещественных чисел
Даны натуральное число п и вещественные числа а1, а2, ..., а10 . Определить среднее арифме-тическое...
Дан файл вещественных чисел. Найти среднее арифметическое его элементов
Дан файл вещественных чисел. Найти среднее арифметическое его элементов.
Даны вещественные числа а1, а2, ..., а10. Определить среднее арифметическое вещественных чисел
1)Вычислить приближенно площадь фигуры, об¬разованной кривой у == 0,3(х — l)2+4, осью абс¬цисс и...
Дан файл вещественных чисел. Найти среднее арифметическое его элементов
дан файл вещественных чисел. найти среднее арифметическое его элементов.
Искать еще темы с ответами
Или воспользуйтесь поиском по форуму:
3
ответ Создать тему
Объяснение:
Объём растрового изображения определяется как произведение количества точек и информационного объёма одной точки, который зависит от количества возможных цветов. Для черно-белого изображения информационный объём одной точки равен 1 биту, так как точка может быть либо чёрной, либо белой, что можно закодировать одной из двух цифр — 0 или 1.
Графи́ческий интерфе́йс по́льзователя (ГИП), графический пользовательский интерфейс (ГПИ) (англ. graphical user interface, GUI) — система средств для взаимодействия пользователя с компьютером, основанная на представлении всех доступных пользователю системных объектов и функций в виде графических компонентов экрана (окон, значков, меню, кнопок, списков и т. п.).
В отличие от интерфейса командной строки, в GUI пользователь имеет произвольный доступ (с устройств ввода — клавиатуры, мыши, джойстика и т. п.) ко всем видимым экранным объектам (элементам интерфейса) и осуществляет непосредственное манипулирование ими. Чаще всего элементы интерфейса в GUI реализованы на основе метафор и отображают их назначение и свойства, что облегчает понимание и освоение программ неподготовленными пользователями.
Графический интерфейс пользователя является частью пользовательского интерфейса и определяет взаимодействие с пользователем на уровне визуализированной информации.
PAINT FOTOSHOP
SAVE SAVE ADD ВЫДЕЛИТЬ
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Программа на паскале:
const n=30;
var a: array[1..n] of integer;
p,s,k,i: integer;
begin
writeln('Исходный массив:');
for i:=1 to n do begin
write('a[',i,']=');
readln(a[i]);
end;
writeln;
write('p = ');
readln(p);
s:=0; k:=0;
for i:=1 to n do
begin
if a[i]<0 then s:=s+a[i];
if (a[i]>0)and(a[i]<p) then k:=k+1;
end;
writeln('s = ',s,' k = ',k);
end.
Пример (для n=5):
Исходный массив:
a[1]=4
a[2]=-7
a[3]=8
a[4]=-5
a[5]=3
p = 6
s = -12 k = 2