perfectorg
?>

Дан массив из 12 целых чисел проверить является ли он по возрастанию. написать программу на с++​

Информатика

Ответы

gallows-warlike-0z

Исходник ниже. В задаче говорится, что чисел ровно 12, поэтому сделал статический массив на константное количество элементов. Если предполагается, что программа должна работать и на других размерах массива, то можно сделать динамический массив или использовать контейнер vector.

Объяснение:

#include <iostream>

int main(){

   const int n = 12;

   int a[n];

   for(int i = 0; i < n; i++){

       std::cin >> a[i];

   }

   bool ascending= true;

   for(int i = 1; i < n; i++){

       if (a[i-1] > a[i]){

           ascending = false;

           break;

       }

   }

   if (ascending){

       std::cout << "Yes" << std::endl;

   }

   else{

       std::cout << "No" << std::endl;

   }

   return 0;

}    

Бочкарева Горохова1652

Школьные Знания.com

Какой у тебя во классы Информатика 15+8 б Сформулируйте задачу оптимального планирования для школьного кондитерского цеха, в котором выпускается три вида продукции: пирожки, пирожные и коржики.

По больше объяснений Следить Отметить нарушение Kirata 2 часа назад

ответы и объяснения

nastahamula489

Nastahamula489Новичок

Знаешь ответ? Добавь его сюда!

adamzalimhanov

AdamzalimhanovХорошист

Шанежки 751

Пирожные 341

Прибыль эквивалентна стоимости 2898 пирожков

Объяснение:

Пусть цех производит 4 вида продукции:

Пирожки (максимально возможно произвести 2000 шт. в день, если ничего больше не производить)

Шанежки (максимально возможно произвести 1500 шт. в день)

Булочки (максимально возможно произвести 1200 шт. в день)

Пирожные (максимально возможно произвести 700 шт. в день).

Соотношение стоимости изделий таково: пирожок/булочка - 2/1 пирожок/шанежка - 1/2 пирожок/пирожное - 1/4.

Емкость склада равна 1100 изделий. Составить оптимальный план выпуска продукции для достижения максимальной выручки.

Sharap

Объяснение:

No or not?

Grammar > Easily confused words > No or not?

из English Grammar Today

No and not are the two most common words we use to indicate negation. We use no before a noun phrase:

There’s no address on the envelope.

[parent to child]

No biscuits before dinner!

No decisions have been made.

We use not with any other phrase or clause:

It’s not often that you stop and think about the way you breathe.

Not suitable for children under 15.

Not surprisingly, it was a tense match but eventually the more experienced Australians won.

A:

Do you go cycling all year round?

B:

Not in the winter.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив из 12 целых чисел проверить является ли он по возрастанию. написать программу на с++​
Ваше имя (никнейм)*
Email*
Комментарий*