docvet4
?>

1) дана строка s, содержащая слово "". найти номер позиции данного слова. 2) вводится строка из двух слов, разделённых пробелом. составьте программу, позволяющую вставить слово t после первого слова строки s. строку s и слово t ввести с клавиатуры. пример ввода: входные данные – наступила осень (строка s), золотая (слово t выходные данные – наступила золотая осень.

Информатика

Ответы

proea
Не особо знаю паскаль, так что дабы не накосячить с синтаксисом, покажу на примере. Тут всё просто - тебе лишь нужен цикл For и расчет процентов.

FOR i = 1 TO 100
percents = FIX(x * p / 100) ' здесь у нас есть переменная percents, которой присваиваются округленные функцией fix проценты (насколько я знаю, в паскале аналогичная функция называется Round)
x = x + percents 'тут всё понятно - переменной X присваивается она сама и годовые проценты по вкладу
IF x >= y THEN 'проверяем, не равен или не превысил ли наш вклад ожидаемую сумму
PRINT i 'в цикле For можно не заморачиваться с отслеживанием лет, переменная i сама подсчитает количество итераций-лет
END 'завершаем программу
END IF
NEXT i ' конец цикла
Можно ещё чисто для себя добавить в условие вывод переменной X, чтобы было нагляднее.  
kseybar
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) дана строка s, содержащая слово "". найти номер позиции данного слова. 2) вводится строка из двух слов, разделённых пробелом. составьте программу, позволяющую вставить слово t после первого слова строки s. строку s и слово t ввести с клавиатуры. пример ввода: входные данные – наступила осень (строка s), золотая (слово t выходные данные – наступила золотая осень.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

samuilik-v
Golubitskaya378
patersimon1
НиколаевнаФ
Semenova1719
morozov1605
zakaz
petrowanastya202081
atenza3736
kim-1971
Камочкин
mrropevvv
Денис_Петровна
Юлия1972
d43irina
▲