Стадник620
?>

C++ вычисление сложности алгоритма , 1. стандартный алгоритм вычисления количества отрицательных элементов одномерного числового массива из тысячи элементов работает 0, 01 сек. оцените время работы того же алгоритма на том же компьютере, если длина массива миллион элементов. 2. вычислите сложность поиска нулевых элементов в матрице размера мxn. 3. подсчитайте сложность алгоритма сложения двух двоичных чисел, при записи которых использовалось n-цифр.

Информатика

Ответы

mnogomams47
Var
begin
readln(n);
if n=1 then begin writeln('1 месяц');writeln('кол-во дней');end;
if n=2 then begin writeln('2 месяц');writeln('кол-во дней');end;
if n=3 then begin writeln('3 месяц');writeln('кол-во дней');end;
if n=4 then begin writeln('4 месяц');writeln('кол-во дней');end;
if n=5 then begin writeln('5 месяц');writeln('кол-во дней');end;
if n=6 then begin writeln('6 месяц');writeln('кол-во дней');end;
if n=7 then begin writeln('7 месяц');writeln('кол-во дней');end;
if n=8 then begin writeln('8 месяц');writeln('кол-во дней');end;
И так до 12 раз...
Я не уверен что тебе нужен такой монстр...
В место к примеру 1 месяца пишешь январь...
KrisTinka
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadLines('in.txt').ToArray;
  var n:=StrToInt(s[0]);
  var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
  var f:=OpenWrite('out.txt');
  Writeln(f,n,' - (кол-во чисел)');
  foreach var e in a do Write(f,e,' '); Writeln(f);
  Writeln(f,'Среднее значение четных ',
    a.Where(x->x.IsEven).Average);
  Writeln(f,'Среднее значение нечетных ',
    a.Where(x->x.IsOdd).Average);
  f.Close
end.

Файлы in.txt и out.txt находятся во вложении.

Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++ вычисление сложности алгоритма , 1. стандартный алгоритм вычисления количества отрицательных элементов одномерного числового массива из тысячи элементов работает 0, 01 сек. оцените время работы того же алгоритма на том же компьютере, если длина массива миллион элементов. 2. вычислите сложность поиска нулевых элементов в матрице размера мxn. 3. подсчитайте сложность алгоритма сложения двух двоичных чисел, при записи которых использовалось n-цифр.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

PivovarovaIlina1437
azelenkov
alazaref
gusinica23
skrepka397412
Jannadon77
pechyclava
edelstar83
horst58
ftyh6
vik1223
tyrnaus
mikchaylovaalex
Сергеевна
Бурмистров_Салагин1074