ответ:
using system;
using system.collections.generic;
using system.linq;
using system.text;
namespace consoleapplication4
{
class program
{
// дан массив с1, с2, …, с24. в массиве есть два элемента равные 0. заменить все элементы, стоящие между ними, на единицы
static void main(string[] args)
{
const int n = 24; // размер массива
int[] с = new int[n]; // создали массив
for (int i = 0; i < n; i++) // вводим элементы массива
{
с[i] = int.parse(console.;
}
bool check = false; // индикатор замены (пока что выключен)
for (int i = 0; i < n; i++) // цикл для выполнения замены
{
if (с[i] == 0) // если проверемый элемент нулевой, то переулючить индикатор замены и закончить текущую иттерацию
{
check = ! check;
continue;
}
if (check == true) // если индикатор замены включен, то заменяем текущий элемент
с[i] = 1;
}
for (int i = 0; i < n; i++) // выводим элементы массива
{
console.writeline(с[i]);
}
console.readkey(); // ждем нажатия клавиши
}
}
}
объяснение:
ответ:
using system;
using system.collections.generic;
using system.linq;
using system.text;
namespace consoleapplication4
{
class program
{
// дан массив с1, с2, …, с24. в массиве есть два элемента равные 0. заменить все элементы, стоящие между ними, на единицы
static void main(string[] args)
{
const int n = 24; // размер массива
int[] с = new int[n]; // создали массив
for (int i = 0; i < n; i++) // вводим элементы массива
{
с[i] = int.parse(console.;
}
bool check = false; // индикатор замены (пока что выключен)
for (int i = 0; i < n; i++) // цикл для выполнения замены
{
if (с[i] == 0) // если проверемый элемент нулевой, то переулючить индикатор замены и закончить текущую иттерацию
{
check = ! check;
continue;
}
if (check == true) // если индикатор замены включен, то заменяем текущий элемент
с[i] = 1;
}
for (int i = 0; i < n; i++) // выводим элементы массива
{
console.writeline(с[i]);
}
console.readkey(); // ждем нажатия клавиши
}
}
}
объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, по которой будет реализован следующий сценарий: 1. компьютер запрашивает Ваше имя, ввести имя с клавиатуры. 2. компьютер запрашивает Ваш год рождения, ввести год рождения. 3. после ввода компьютер сообщает ваш возраст (количество лет 4. Для расчета от текущего года надо вычесть год Вашего рождения. Например, если ввели имя Иван, год рождения 2005, то выведется фраза «Иван тебе 15 лет». паскаль
PascalABC
Объяснение:
program vozrast;
var
name: string;
year, age: integer;
d: datetime;
begin
Write('Введите имя: ');
ReadLn(name);
Write('Введите год рождения: ');
ReadLn(year);
d := DateTime.Now;
age := d.Year - year;
WriteLn(name,', тебе ', age, ' лет.');
end.