scraer198258
?>

Написать программу на языке C++ (c#) которая вводит целое чило n и массив из n целых чисел и определяет есть ли в массиве число 30.

Информатика

Ответы

Шаленко

C#

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n;

           bool b = false;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           int[] A = new int[n];

           Console.WriteLine("Введите массив: ");

           for (int i = 0; i < n; i++)

           {

               A[i] = Convert.ToInt32(Console.ReadLine());

               if (A[i] == 30) b = true;

           }

           Console.WriteLine("В массиве "+(b ? "есть" : "нет")+" числ"+ (b ? "о" : "а") + " 30");

       }

   }

}

zotti

Передача информации  — физический процесс, посредством которого осуществляется перемещение знаков (сведений предоставлять информацию) в или осуществляется физический доступ субъектов к знакам.

Передача информации — заблаговременно организованное техническое мероприятие, результатом которого становится воспроизведение информации, имеющейся в одном месте (так называемый источник информации), в другом месте (приёмник информации). Данное мероприятие предполагает предсказуемый срок получения указанного результата; «информация» здесь понимается в техническом аспекте, как осмысленное множество символов, чисел, параметров абстрактных или физических объектов, без достаточного «объёма» которого не могут быть решены задачи управления, выживания, развлечения, совершения финансовых операций, каких-либо действий, в т.ч. преступных, и т.д.

Объяснение:

secretar62
В глубокой древности - на стенах пещер, на глиняных табличках, восковых дощечках, на скрижалях, потом на папирусе, бересте, пергаменте и т. д. Потом изобрели бумагу. В старину писали стилом, палочками, гусиными перьями, углями. Были ещё какие-то средства. В девятнадцатом веке изобрели пишущие машинки, фотоаппараты - ведь запечатление изображений на фотоплёнках и фотопластинках, это тоже запись информации. Также в 19 столетии появились граммофоны, патефоны, механические пианино, шарманки (музыка - тоже информация) . А уже ближе к нашим временам появились магнтитофоны, видеомагнтитофоны, потом лазерные устройства для записи на диски. Наконец, мобильники, фотоаппараты, компьютеры - это тоже накопители информации, которая хранится на дисках, флэшках, картах памяти и т. д. В общем, сам поищи в интернете, напиши разные варианты для поиска, например, "древние записи информации", "старинные носители информации", "папирус, глина, берестяные грамоты, письмена", "Александрийская библиотека" и т. д.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке C++ (c#) которая вводит целое чило n и массив из n целых чисел и определяет есть ли в массиве число 30.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yuda12
targovich
Васильевич Валерьевна
zigrin
red-sun2
st-op767840
staskamolbio5152
mayorovmisc6
Присакарь520
svt5299
Zashchitin Denis
nikdenly
Anna Artem
rosik76
Анатольевич-Лариса