Guru-tailor
?>

Напишите программу, которая определяет самые секретные секреты Мэри Поппинс. Во введенной строке много раз повторяются слова Мэри Поппинс, а между ними написаны ее секреты. Нужно найти только те, в которых есть пробелы. И вывести через точку и пробел. Формат ввода Вводится строка. Формат вывода Вывести в строку через точку и пробел все секреты Мэри Поппинс, в которых есть пробелы. Пример 1 Ввод Вывод ее принес восточный ветер Мэри Поппинс няня Мэри Поппинс здоровое питание Мэри Поппинс ковровая сумка Мэри Поппинс улыбка ее принес восточный ветер. здоровое питание. ковровая сумка Пример 2 Ввод Вывод(пусто) Леди Мэри Поппинс няня

Информатика

Ответы

mayorovmisc6

Відповідь:

Дивись фото

Пояснення:

<!DOCTYPE html>

<html>

<head>

  <title>Price</title>

  <meta charset="utf-8">

</head>

<body>

 <p>стоимости переговоров</p>

</body>

<script>

 {/*Написать логическое выражение для определения стоимости переговоров, если стоимость переговоров с 22 часов до 8 часов на 20% ниже, а в субботу и в воскресенье дополнительно предоставляется скидка 10%. */}

 t = +prompt('время разговоров от 0 до 24 часов')

 dt = +prompt('продолжительность разговора в минутах')

s = +prompt('стоимость минуты разговора')

 d = +prompt('день недели от 1 до 7')

 console.log('t=',t,'dt=', dt, 's=', s, 'd=', d)

 function Price (t, dt, d, s) {

  let startTalk = t*60

  let price = 0

  console.log('day = ', d)

 

  for (let i =1; i<=dt; i++){

   let night = false

   let holiday = false

   let p = s

   

   if( (startTalk+i)%1440 === 0 ){

    if (d<7){

     d=d+1

     console.log('day = ', d)

    } else {

     d=1

     console.log('day = ', d)

    }

   }

   if ( (startTalk+i)%1440>=1320 || (startTalk+i)%1440<480){

    night = true

   }

   if ( d === 6 || d===7){

    holiday = true

   }

   if (night){

    p = p - s*0.2

   

   }

   if (holiday){

    p = p-s*0.1

   }

   price = price+p

   

   console.log('стоимости '+ i+'мин. = '+ p.toFixed(2)+'$')

  }

  console.log('fin.price', price.toFixed(2), '$')

  return price.toFixed(2)

 }

 {/*Price(t, dt, d, s)*/}

 alert('стоимости переговоров  ' + '$' + Price(t, dt, d, s))

</script>

</html>


Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
Витальевна

program ExampleN;

uses Math;   // объявление математических функций для вашей версии паскаля

var

 a, b, d, s, y1, y2, x: Double;

begin

 Write ('Введете границы отрезка: ');

 ReadLn (a, b);

 s := 0;

 d := (b - a) / 10;             // длина 1/10 отрезка

 x := a + d / 2;                // начальное значение Х = левая граница + половина отрезка (середина основания)

 while x < b do begin           // цикл по всей длине отрезка

   y1 := Sqr (x);

   y2 := 5 + x / 2;

   s := s + Abs (y1 - y2) * d;  // расчет площади прямоугольника и суммирование

   x := x + d;                  // увеличение Х на 1/10 отрезка

 end;

 WriteLn ('Площадь = ', s :20 :10);

 ReadLn;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая определяет самые секретные секреты Мэри Поппинс. Во введенной строке много раз повторяются слова Мэри Поппинс, а между ними написаны ее секреты. Нужно найти только те, в которых есть пробелы. И вывести через точку и пробел. Формат ввода Вводится строка. Формат вывода Вывести в строку через точку и пробел все секреты Мэри Поппинс, в которых есть пробелы. Пример 1 Ввод Вывод ее принес восточный ветер Мэри Поппинс няня Мэри Поппинс здоровое питание Мэри Поппинс ковровая сумка Мэри Поппинс улыбка ее принес восточный ветер. здоровое питание. ковровая сумка Пример 2 Ввод Вывод(пусто) Леди Мэри Поппинс няня
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rastockin8410
ПогальниковАлёна589
Юлия1972
anazarov80
Isaeva_Marin1010
tofilev
rezh2009766
kononova_Pavel689
laktionova-natal
Коваль1974
rigina82
mskatrinmadness
guujuu
Остап-Лаврова1410
irina611901
▲