triumfmodern
?>

Исправьте ошибку , я выполнял задание Напишите программу, которая для произвольного натурального двузначного числа определяет сумму и произведение его цифр var x, a, b, c, d: integer; begin writeln ('число'); readln (x); a:=x mod 10 ; b:=x mod 10; c:=a*b; d:=a+b; writeln ('произведениеc=', c); writeln ('сумма=', d); end.

Информатика

Ответы

korneevaa

Для определения информационного объема сообщения воспользуемся формулой: I = K * i,  где K - количество символов, i - вес одного символа.

1)  1024 стра­ни­цы, на одной стра­ни­це по­ме­ща­ет­ся 64 стро­ки, а в стро­ке по­ме­ща­ет­ся 64 сим­во­ла. Каж­дый сим­вол в ко­ди­ров­ке КОИ-8 за­ни­ма­ет 8 бит па­мя­ти.

i = 8 бит

K = 1024 * 64 * 64 = 4194304 символов,

I = 4194304 * 8 = 33554432 бит = 4194304 байт = 4096  Кбайт = 4 Мбайт

2) 512 стра­ниц, на одной стра­ни­це в сред­нем по­ме­ща­ет­ся 64 стро­ки, а в стро­ке 64 сим­во­ла. (Каж­дый сим­вол в ко­ди­ров­ке Unicode за­ни­ма­ет 16 бит па­мя­ти.)

i = 16 бит

K = 512 * 64 * 64 = 2097152 символов,

I = 2097152 * 16 = 33554432 бит = 4194304 байт = 4096 Кбайт = 4 Мбайт

*8 бит = 1 байт

1024 байт = 1 Кбайт

1024 Кбайт = 1 Мбайт

edvard-b

1) print ('s [2,7] =', s [2,7])  Error: TypeError

2) print ('s [5:] =', s [5: 1)  Error: SyntaxError

3) print ('s [: 4] =', S [: 4])  Error: NameError

4) print ('s [: - 3] =', s [: - 3])  "информат"

Объяснение:

Что выведет программа в 1, 2 и 3 сам бог знает...

В первом случае предполагаю что хотели вывести 3 и 8 символ, но нельзя выводить их так.

Во втором нет закрывающей квадратной скобки.

В третьем откуда взялась переменная S??? Python не Pascal и различает регистр в названиях переменных.

В четвёртом. Число после ":" означает что берётся первые N элементов, а остальные отбрасываются. Знак "-" перед 3 означает что сначала строка переворачивается и обрезается.

информатика (действует минус) == акитамрофни (программа обрезает 3 знака) == тамрофни (и возвращает неперевёрнутую строку) = информат

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Исправьте ошибку , я выполнял задание Напишите программу, которая для произвольного натурального двузначного числа определяет сумму и произведение его цифр var x, a, b, c, d: integer; begin writeln ('число'); readln (x); a:=x mod 10 ; b:=x mod 10; c:=a*b; d:=a+b; writeln ('произведениеc=', c); writeln ('сумма=', d); end.
Ваше имя (никнейм)*
Email*
Комментарий*