Nikita_Lina1305
?>

На вход программе подается натуральное число n, затем n строк, затем еще одна строка — поисковый за Напишите программу, которая выводит все введенные строки, в которых встречается поисковый за Формат входных данных На вход программе подаются натуральное число nn — количество строк, затем сами строки в указанном количестве, затем один поисковый за Формат выходных данных Программа должна вывести все введенные строки, в которых встречается поисковый за Примечание. Поиск не должен быть чувствителен к регистру символов. Пример входных данных: 5 Я вас любил: любовь еще, быть может, В душе моей угасла не совсем; Но пусть она вас больше не тревожит; Я не хочу печалить вас ничем. Я вас любил безмолвно, безнадежно, Любил Вывод программы: Я вас любил: любовь еще, быть может, Я вас любил безмолвно, безнадежно,

Информатика

Ответы

stasletter
Какие такие графические оболочки?
неужто линукс?

KDE - или кеды, самые дружелюбные к пользователю
пример кедов на скрине (ток у меня специально упрощенный)

GNOME2 - отличная оболочка раньше была, но перешли на кеды, так как на смену пришел GNOME3

GNOME3 - многие плюются, многие восхищаются
кому как, мне лично понравилось, но пробыл с ним 2-3 месяца

XFCE - легкая оболочка, для нетбуков и т.п. - отличная вещь

LXDE - легкая оболочка, однако хоть и легче немного XFCE, но работать с ней - мазохизм

UNITY - столько радужных слов хочется сказать
уж слишком тормозит на древнегреческих компах
уж слишком много ресурсов ест
уж слишком много анимации
+ не удобное меню
используют его как правило ламеры/хомячки которые сидят на бубунту, и не знают, что есть другие оболочки

Отличаются как правило - заводскими программами при установке

Чем различаются типы графических оболочек
Чем различаются типы графических оболочек
postbox

//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".

var

 a, b, c: array [1..100] of longint;

 i, min, n, j, t: longint;

begin

 //Читаем количество элементов в нашем массиве.

 readln(n);

 

 //Читаем массив.

 for i := 1 to n do read(a[i]);

 

 //Заполняем первую "половинку".

 for i := 1 to n div 2 do b[i] := a[i];

 

 //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и

 //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.

 for i := n div 2 + 1 to n do c[i - n div 2] := a[i];

 

 //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода

 //основывается на том, что мы ищем минимальный среди неотсортированных элемент,

 //а затем аем его с тем, который стоит сразу после отсортированных.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if b[min] > b[j] then

       min := j;

   if min <> i then begin

     t := b[i];

     b[i] := b[min];

     b[min] := t;

   end;

 end;

 

 //Затем вторую точно также, только стоит обратить внимание на сравнения.

 //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом

 //будет другим.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if c[min] < c[j] then

       min := j;

   if min <> i then begin

     t := c[i];

     c[i] := c[min];

     c[min] := t;

   end;

 end;

 

 //А теперь по очереди выводим готовые "половинки", не забывая ставить

 //пробел после вывода каждого элемента.

 for i := 1 to n div 2 do write(b[i], ' ');

 for i := 1 to n - n div 2 do write(c[i], ' ');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программе подается натуральное число n, затем n строк, затем еще одна строка — поисковый за Напишите программу, которая выводит все введенные строки, в которых встречается поисковый за Формат входных данных На вход программе подаются натуральное число nn — количество строк, затем сами строки в указанном количестве, затем один поисковый за Формат выходных данных Программа должна вывести все введенные строки, в которых встречается поисковый за Примечание. Поиск не должен быть чувствителен к регистру символов. Пример входных данных: 5 Я вас любил: любовь еще, быть может, В душе моей угасла не совсем; Но пусть она вас больше не тревожит; Я не хочу печалить вас ничем. Я вас любил безмолвно, безнадежно, Любил Вывод программы: Я вас любил: любовь еще, быть может, Я вас любил безмолвно, безнадежно,
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ogofman
astahova
grekova5
aaltuxova16
bespalovaannaanna
Barabanov Gerasimenko
спец Михасов
morsh9345
barnkim
Solovetzmila
goldglobustour725
ВадимСмирнов116
спец Михасов
vasearu
asvavdeeva