Akolomaeva4
?>

Составьте программу для вычисления значений функции y=x sqrt (5+x Аргумент функции x изменяется от - 5 до 5 с шагом 1. Вывести в окно результатов только положительные значения функции

Информатика

Ответы

vodolaz8384
К сожалению, ты не написал на каком тебе надо языке, я выбрал JavaScript
1) var array = [4,5,10,-10,5]; 
var min = 1000000;
for (var i = 0; i < 5; i++) {
if (min>array[i]) {
min = array[i];
 }
 }
alert("Минимальный элемент + "min);

2)var array = [];
for (var i = 0; i < 5; i++) {
var number = prompt("Введите число");
 array.push(number);
}
alert("Ваш массив " + array);
var min = 1000;
var max = 0;
for (var j = 0; j < 5; j++) {
  if (min > array[j]) {
  min = array[j];
  }
}
alert("Минимум = " + min);
for (var k = 0; k < 5; k++) {
if (max < array[k]) {
  max = array[k];
 }
}
alert("Максимум = " + max);
yurick2071488
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

Нулевой шаг: создание типизированного файла нужной структуры

begin
  var f:file of real;
  Assign(f,'MyReal.bin'); Rewrite(f);
  loop 2 do begin
    SeqRandomInteger(10,1,100).Select(t->t/10).ForEach(t->Write(f,t));
    SeqRandomInteger(10,-100,-1).Select(t->t/10).ForEach(t->Write(f,t));
    end;
  f.Seek(0); // начало файла
  var b:real;
  while not Eof(f) do begin Read(f,b); Print(b) end;
  Println;
  f.Close
end.

Пример:
9.7 1 4.1 8.3 5.6 9.3 2.2 9.3 5.8 8.8 -8.8 -7.7 -1.4 -5.2 -7.2 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 4.5 10 4.5 6.1 0.7 -8 -0.8 -3.3 -9.5 -7.9 -0.9 -7.4 -9.4 -1.8 -4.6

Собственно, программа

begin
  var f1,f2:file of real;
  Assign(f1,'MyReal.bin'); Reset(f1);
  if f1.FileSize mod 20<>0 then begin
    Writeln('Количество компонент во входном файле не кратно 20');
    Exit
    end;
  Assign(f2,'MyReal2.bin'); Rewrite(f2);
  var buf:=new real[5];
  var b:real;
  while not Eof(f1) do begin
    // переписываем пять положительных
    loop 5 do begin Read(f1,b); Write(f2,b) end;
    // считываем пять положительных в буфер
    for var i:=0 to 4 do Read(f1,buf[i]);
    // переписываем пять отрицательных
    loop 5 do begin Read(f1,b); Write(f2,b) end;
    // пишем пять положительных из буфера
    foreach var t in buf do Write(f2,t);
    // переписываем пять отрицательных
    loop 5 do begin Read(f1,b); Write(f2,b) end
    end;
  f1.Close;
  // контрольное чтение 
  f2.Seek(0); // к началу 
  while not Eof(f2) do begin Read(f2,b); Print(b) end;
  Writeln; 
  f2.Close
end.

Пример
9.7 1 4.1 8.3 5.6 -8.8 -7.7 -1.4 -5.2 -7.2 9.3 2.2 9.3 5.8 8.8 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 -8 -0.8 -3.3 -9.5 -7.9 4.5 10 4.5 6.1 0.7 -0.9 -7.4 -9.4 -1.8 -4.6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для вычисления значений функции y=x sqrt (5+x Аргумент функции x изменяется от - 5 до 5 с шагом 1. Вывести в окно результатов только положительные значения функции
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arnaut-anna
Yelizaveta555
dionissia2
marinazubcko16729
Vasilii1891
Volodka
VASILEVNA
tanyatanyat
gameover98
gymnazium
nataliaprintroll
Александровна1685
cochana
Романенко
yuip2008