Bni1504
?>

всем привет ЧРОЧНО НАДО решить задачу по информатике (написать программу): на прямой отмечены последовательно пронумерованные не совпадающие точки от 1 до n . выведите номер точки ближайшей к первой точке, чтобы сумма расстояний от всех остальных точек к этой точке была наименьшей.

Информатика

Ответы

kononenko-elena4

Ветвление – это команда алгоритма, в которой делается выбор, выполнять или не выполнять какую-нибудь группу команд в зависимости от условий. Ветвление используется в двух случаях:

Когда в алгоритме есть действия, которые иногда нужно пропускать (в зависимости от какого-то условия).

Когда в алгоритме нужно записать выбор  тех или иных действий (в зависимости от какого-нибудь условия).

В блок-схеме условие ветвления записывается в ромбе, из которого выходят обязательно 2 стрелки. Стрелка «Да» указывает на команды, которые должны выполняться, когда условие соблюдается. Стрелка «Нет» указывает на команды, которые должны выполнятся, когда условие не соблюдается.

ii090758
 const nx = 20;
var x: array[1..nx, 1..nx] of integer;z:array[1..nx*2] of integer; 
i, j, k,n,r,t: integer; 
begin 
Writeln('Введите размер матрицы n');Read(n); 
 for i := 1 to n do begin   
for j := 1 to n do begin   
Read(k);x[i, j] := k;  end;end;   
Writeln('Исходный массив'); 
for i := 1 to n do begin   
for j := 1 to n do begin     
Write(x[i, j]:4);     
if x[i, j]>0 then begin t:=t+1; z[t]:=x[i, j];end;    
end;   
Writeln;  end; 
Writeln;Writeln('Одномерный массив'); 
for j := 1 to t do     
Write(z[j]:4); 
 end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

всем привет ЧРОЧНО НАДО решить задачу по информатике (написать программу): на прямой отмечены последовательно пронумерованные не совпадающие точки от 1 до n . выведите номер точки ближайшей к первой точке, чтобы сумма расстояний от всех остальных точек к этой точке была наименьшей.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vik-2202
merx80
lihacheva
marinazubcko16729
dmitrymakarov003
mg4954531175
Strelkov-Roman1263
родичева1812
Lorik-lorik29
bezpalova2013
annakorolkova79
Нескажу25
Кириллов57
mirogall
ka-shop
▲