nusupova
?>

10. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO» Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет на языке программирования питон

Информатика

Ответы

delonghisochi

mass = [int(s) for s in input().split()]

k = 0

a = 0

for i in range(len(mass)):

   if mass[i] % 8 == 0:

       a += mass[i]

       k += 1

if k == 0:

   print('NO')

else:

   print(a / k)

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

10. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO» Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет на языке программирования питон
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Сергеевна-Иван1045
happygal5224
mashere59
kareeva
fmba18
volna22051964
olechka197835
Daniil1945
lena260980
Любовь
ПетровичЖивотовская1245
tyrnaus
Ирина
volchek01112240