OOO"Kiprei"_Aleksandr1938
?>

Ассемблер Написать программу, которая вычисляет значение функции f(x)=(x - a) * (x - b) + d где a=2, b=-3, d=5, x=7

Информатика

Ответы

aromastil88
using System;
using System.IO;
using System.Linq;

namespace FileApp
{
    class MainClass
    {      
        private static int Multicast(char first,char second, int system)
        {
            return Convert.ToInt32(first.ToString(), system) * Convert.ToInt32(second.ToString(), system);
        }

        private static void Method(string numberString,int system)
        {
            int firstAndSecond = Multicast(numberString[0], numberString[1], system); // Первые два
            int lastAndPrevious = Multicast(numberString.Last(), numberString[numberString.Length - 2], system); //Последний и предпоследний
            int firstAndLast = Multicast(numberString.First(), numberString.Last(), system); // Первый и последний
            
            Console.WriteLine($"Произведение первых двух цифр: {firstAndSecond}");
            Console.WriteLine($"Произведение последних двух цифр: {lastAndPrevious}");
            Console.WriteLine($"Произведение первой и последней цифры: {firstAndLast}");
        }

        public static void Main(string[] args)
        {
            Console.Write("Введите число: ");
            string numberString = Console.ReadLine(); //Число в виде строки

            Console.Write("Выберите систему счисления: ");
            int system = Convert.ToInt32(Console.ReadLine());//Система счисления

            Method(numberString, system);

            Console.ReadLine();//Задержка
        }
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ассемблер Написать программу, которая вычисляет значение функции f(x)=(x - a) * (x - b) + d где a=2, b=-3, d=5, x=7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mariavayda88734
annayarikova
ti2107
Margarita
diana0720
dmdlir
jenn055
tshelokova
ПолухинаТененева565
oskina3
konnovakat1
fancy-decor67
drevile57
Manyaya
elmira070485
▲