Ladiga_Evgenii886
?>

Составьте программу табулирования функции y(x), выведите на экран значения x и y(x программирование на С#

Информатика

Ответы

Bologova Golovach1989
Написано и протестировано в PascalABC.NET (версия 2.2, сборка 842)
const
 s='велосипедист';
var
 t:='кытунак';
 p:string;
begin
  // 1
  Writeln(LeftStr(s,9),', ',
    s[12]+s[2]+s[5]+s[12]+s[4],', ',
    s[4]+Copy(s,3,2)+s[1]+s[4]);
  // 2
  Writeln('Позиция буквы "д" в слове "'+s+'" равна ',s.IndexOf('д')+1);
  // 3
  Write('Было: ',t,', стало: ');
  t[2]:='о'; t[4]:='е'; t:=t.Replace('а','о');
  Writeln(t);
  // 4
  Write('Коды символов слова ',t,': ');
  foreach c:char in t do Write(Ord(c),' ');
  Writeln;
  // 5
  Write('В слове ',t,' количество букв ');
  if Odd(t.Length) then Writeln('нечетное') else Writeln('четное')
end.

Результат выполнения программы:
велосипед, тесто, олово
Позиция буквы "д" в слове "велосипедист" равна 9
Было: кытунак, стало: котенок
Коды символов слова котенок: 234 238 242 229 237 238 234
В слове котенок количество букв нечетное

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу табулирования функции y(x), выведите на экран значения x и y(x программирование на С#
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Minchenkova
slitex
adel25159
Galkin683
nastyakrokhina87
koxhulya61
a800000
Середа-Сергеенков980
Batrakova-Anna
orange-salon-job77
okykovtun31
озерская_Мария1234
Fedorov1283
Тарбаева1243
Есартия52