sveta740450
?>

Вопрос на картинке если что уточнюеще номер 6. чему будет равно значение переменной х после выполнения фрагмента программы, обрабатывающей массив a[1..n] ? *

Информатика

Ответы

Stanislavovna1237
#include < stdio.h> #include < stdlib.h> #include < locale.h> int main(void) {       setlocale(lc_all, "russian");       int n, iuneven = -1;       scanf("%d", & n);       int *a = (int*)malloc(n * sizeof(int));       for (int i = 0; i < n; i++)             scanf("%d", & a[i]);       for (int i = 0; i < n; i++)             if (a[i] % 2 == 1)             {                   iuneven = i;                   break;             }       free(a);       iuneven == -1 ? printf("нечетное число не найдено\n") : printf("%d\n", iuneven);             return 0; }
Milovidova
Var n1,n2,n3,n4,n5: integer; begin readln(n1,n2,n3,n4,n5); if (n1> n2)  and (n1> n3)  and (n1> n4)  and (n1> n5)  then writeln('максимальное число: ',n1) else if (n2> n1)  and (n2> n3)  and (n2> n4)  and (n2> n5)  then writeln('максимальное число: ',n2) else if (n3> n1)  and (n3> n2)  and (n3> n4)  and (n3> n5)  then writeln('максимальное число: ',n3) else if (n4> n1)  and (n4> n3)  and (n4> n2)  and (n4> n5)  then writeln('максимальное число: ',n4) else writeln('максимальное число: ',n5); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вопрос на картинке если что уточнюеще номер 6. чему будет равно значение переменной х после выполнения фрагмента программы, обрабатывающей массив a[1..n] ? *
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

An-solomon
Анна егорович526
Zhilinoe134
maximovpavel9114
ajsklan
Гарик383
Милита1065
КутузоваМартенюк
delfinmos
Aleksei806
atlantika7
Овчинников_Грузман
GridnevaVNIGNI&quot;
Yelena Kotova
sodrugestvo48