?>
Запишите на языке паскаль программы для решения следующих , используйте оператор while: 1) запас рыбы в пруду оценен в а тонн. ежегодный прирост рыбы составляет 15%. ежегодный план отлова - в тонн. наименьший запас рыбы составляет с тонн. (запас ниже с тонн уже не восстанавливается.) составьте программу для подсчёта количества лет, в течение которых можно выдерживать заданный план. 2) дана последовательность 5, 9, 13, 17, . составьте программу для определения числа слагаемых, сумма которых равна 324. 3) составьте программу для определения количества цифр в записи произвольного натурального числа. 4) сумма 10000 рублей положена в сберегательный банк, при этом прирост составляет 5% годовых. составьте программу, определяющую, через какой промежуток времени первоначальная сумма увеличиться в 2 раза. решите, , хотя бы одну-две!
Ответы
program raf105;
var
b,c,let: integer;
a: real;
begin
write('запас рыбы в пруду: ');
readln(a);
write('ежегодный план отлова: ');
readln(b);
write('наименьший запас: ');
readln(c);
while a > = c do
begin
let+= 1;
a: = a+a/100*15;
a-= b;
end;
writeln('заданный план можно выдержать в течении ',let,' лет.');
end.
2.program raf105;
var a,sum,counter: integer;
begin
a: =1;
while sum< > 324 do
begin
a+= 4;
sum+= a;
counter+= 1;
end;
writeln('число слагаемых: ',counter);
end.
3.program raf105;
var a,counter: integer;
begin
write('введите число: ');
readln(a);
while a< > 0 do
begin
counter+= 1;
a: = a div 10
end;
writeln('количество цифр: ',counter);
end.
4.program raf105;
var
a: real;
let: integer;
begin
a: = 10000;
while a< 20000 do
begin
let+=1;
a+= a/100*5;
end;
writeln('сумма увеличится в 2 раза через ',let,' лет');
end.
язык pascalabc