bulin2001
?>

Написать программу которая находит сумму цифр числа и из большей суммы вычесть меньшую

Информатика

Ответы

Alenachernika9111

ответ:

программа на базе pascal

объяснение:

lulu777
Var k, s, i: integer; beginreadln(k); s: =k mod 10; i: =0; while k< > 0 do begin k: =k div 10; if s< k mod 10 then  begins: =k mod 10; i: =0; end; if s=k mod 10 theni: =i+1; end; writeln(i); end. в переменной k вводим число, в переменной s храним максимальную цифру, в переменной i подсчитываем вхождение максимальной цифры в число var k, s, i: integer; beginreadln(k); //вводим числоs: =k mod 10; //предполагаем что последняя цифра - максимальнаяi: =0; // инициализируем счетчик нулемwhile k< > 0 do begin//цикл идет до тех пор пока не закончатся цифры в k k: =k div 10; // отбрасываем цифру  от числа if s< k mod 10 then //если s < последней цифры kbegins: =k mod 10; //то меняем нашу максимальную цифру на новуюi: =0; // и сбрасываем счетчикend; if s=k mod 10 then// если цифра в числе равна максимальной цифреi: =i+1; //прибавляем 1 к счетчикend; writeln(i); //выводим количество вхождений максимальной цифры  end.
Valerevna Tuzova
•процессор socket-1155 intel core i3-2100, 3,1 ггц — 4390 руб.; • материнская плата socket-1155 asrock ddr3 matx ac’97+lan+ vga — 1850 руб.; • корпус компьютера с блоком питания мощностью 400 в — 2480 руб.; • модули оперативной памяти объемом 8 гбайт — 2010 руб.; • жесткий диск объемом 500 гбайт — 3100 руб.; • видеокарта с объемом видеопамяти 2 гбайта — 5880 руб.; • мышь оптическая — 200 руб.; • клавиатура — 180 руб.; • монитор lcd, диагональ 20 дюймов — 5870 руб.; • привод cd-rw — 830 руб.; • модем — 940 руб.; • звуковая карта и • сетевая карта 10/100/1000 мбит/с не нужны так как в материнской плате они уже есть

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая находит сумму цифр числа и из большей суммы вычесть меньшую
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tkmandarin8376
Grishanin
filimon131262
Panei
Рощак_Ольга573
EVLAMPIN56
zimbickij19
amarantmetall
saltikovaK.S.1482
ekvld708
petrovichvit2933
ainetdinovsnab
Alekseeva_Khlistov
arturcristian
Vitalevich1799