Leonidovich_Elena771
?>

Составить программу на basice, которая будет выводить на экран 10 слов составленного из исходного слово: программа составленные слова: опа, пара, грамм, маг, порог, гамма, рама, гора, рога, мама

Информатика

Ответы

shilinmikhaillg
CONST w = "программа"
'          123456789
CLS
PRINT MID$(w, 3, 1) + LEFT$(w, 1) + RIGHT$(w, 1)
PRINT LEFT$(w, 1) + RIGHT$(w, 1) + MID$(w, 2, 1) + MID$(w, 6, 1)
PRINT MID$(w, 4, 5)
PRINT RIGHT$(w, 2) + MID$(w, 4, 1)
PRINT LEFT$(w, 1) + MID$(w, 3, 1) + MID$(w, 2, 3)
PRINT MID$(w, 4, 1) + RIGHT$(w, 4)
PRINT MID$(w, 5, 3) + RIGHT$(w, 1)
PRINT MID$(w, 4, 1) + MID$(w, 3, 1) + MID$(w, 5, 2)
PRINT MID$(w, 2, 3) + RIGHT$(w, 1)
PRINT RIGHT$(w, 2) + RIGHT$(w, 2)

Результат выполнения программы
опа
пара
грамм
маг
порог
гамма
рама
гора
рога
мама
Олегович Паутова
1) 108х40х56х2=483840 количество байт на страницах, +18х28+14х28х2=1792 дополнительные страницы, складываем это все получается...483840+1792=485632, переводим в мегобайты 0,46 мегобайт. 
(если есть вопросы по решению пиши)
2)1-бит вес одного символа, 2 бита в юникоде. 96х32х56=17203248х8х6=2304 количество символов которые отсуствует из-за иллюстаций. 172032-2304=169728 количество символов. Каждый рисунок весит 1.5 килобайта=1536 байт. 1536х6=9216 байт весят рисунки. 169728+9216=178944 байт, переводим в килобайты= 174,75 килобайт. 
Николаевна1564
Program Pascal1;

const
N = 5; M = 6;

var
A: array [1..N, 1..M] of integer;
i, j, k: integer;
s: real;

begin
cls;
k := 0; s := 0;
randomize;
for i := 1 to N do
begin
for j := 1 to M do
begin
A[i, j] := random(50) - 10;
write(A[i, j]:6);
s := s + A[i, j] //Сумма элементов
end;
writeln
end;
s := s / (N * M); //Среднее арифметическое (сумму делим на количество ВСЕХ чисел)
writeln('Srednee ', s:0:3);
for i := 1 to N do
for j := 1 to M do
if a[i, j] > s then k := k + 1; //Считаем элементы большие среднего
writeln('Kolichestvo ', k)
end.

Для всего массива, для второй половины допиши сам

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на basice, которая будет выводить на экран 10 слов составленного из исходного слово: программа составленные слова: опа, пара, грамм, маг, порог, гамма, рама, гора, рога, мама
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Li-111
ooo-helpvet44
losevev5619
books
bugaevnicky
ann-perminova2008
Ivanovich-A.V
pechinin
schernov
Igor120
kalina1372
Илья_Ветклиники1655
studiojanara
catmos
evamining
▲