jurys71242
?>

Составить программу, в которой посчитать кол-во гласных в строке. (в pascal)(тема: двумерные массивы)

Информатика

Ответы

Neveselova

program raf105;

var a: array[1..100,1..2] of char;

glas,s: string;

i,j,sumglas: integer;

begin

glas: ='аеёиоуыэюя'; // перечисление гласных

for i: =1 to length(glas) do

  a[i,2]: = glas[i]; //заполнение второй строки для гласных

writeln('введите строку');

readln(s);

for i: =1 to length(s) do

  a[i,1]: = s[i]; //заполнение первой строки для введённых букв

for i: =1 to length(s) do

  for j: =1 to length(glas) do

    if a[i,1] = a[j,2] //если символ из строки 1 = символу из строки 2

      then sumglas: = sumglas+1; //прибавление единицы к счётчику

writeln('в строке ',sumglas,' гласных');

end.

pastore
Const n=10; m=5; var a: array[1..n,1..m+1] of integer; i,j,k,sp,s: integer; begin randomize; writeln('   результаты соревнований'); for i: =1 to n do   begin   s: =0;   for j: =1 to m do   begin   a[i,j]: =random(50)+50;   write(a[i,j]: 4);   s: =s+a[i,j];   end;   a[i,m+1]: =s;   writeln(s: 5);   end; write('k='); readln(k); sp: =0; for i: =1 to n do   if a[i,m+1]> =k then sp: =sp+1; writeln('sp=',sp); end. пример:   результаты соревнований   69   52   91   62   65   339   70   53   96   56   97   372   78   98   94   61   62   393   62   86   50   58   95   351   82   98   53   56   81   370   75   64   56   85   54   334   69   99   53   72   97   390   55   75   66   59   61   316   99   71   83   75   51   379   91   73   53   88   79   384 k=350 sp=7
magsh99
Они все "неправильные", потому что в каждом из вариантов тело цикла содержит один оператор. в случаях а) и с) это оператор присваивания, в случае б) - условный оператор. если бы тело цикла содержало более одного оператора, то по правилам языка паскаль, эти операторы заключались бы в операторные скобки end. подозреваю, что правильный ответ должен быть б), но дело в том, что оператор присваивания d: =d+1 принадлежит не телу цикла, а условному оператору, находящемуся в теле цикла, а для цикла оператор один - условный.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, в которой посчитать кол-во гласных в строке. (в pascal)(тема: двумерные массивы)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Karpova
alyonafialka
verynzik66525
Алексеевич620
Avshirokova51
Valerevna-Vardan
Columbia777
Сергеевич1386
mali2681208
kulikovtsud
Эвелина
sveta300856729
Yevgenevich775
kun1969
veronica1344